Mind Net

[ 라우터 명령어 집합2 ] - Cisco Router 본문

IT Study/Network 참고 자료

[ 라우터 명령어 집합2 ] - Cisco Router

sungchan41 2014. 2. 11. 16:56
Cisco router 설정 및 개념


▲ router 부팅 과정
메모리 종류
내 용
Rom(EEPROM)
부트스트랩 프로그램
IOS 이미지 파일을 찾아내는 역할
RAM(기본 메모리)
IOS 복사본의 구동(플래시 메모리의 로드)
구성파일의 복사본 구동(NVRAM으로부터의 로드)
라우팅 테이블/ARP테이블
RAM(공유 메모리)
처리를 기다리는버퍼내의 패킷
플래시 메모리
시스코 IOS 이미지
NVRAM
구성파일

※ Rom(post : power - on - self - test) ⇒ RAM(Flash 메모리로부터 IOS 이미지 로드)
⇒ RAM(NVRAM의 설정파일 로드) ⇒ 실행
: 라우터 전원 on, 부트스트랩 프로그램을 로드하고, 여기에서 IOS 이미지 파일의 위치를 알아낸다
다음으로 IOS가 메모리로 읽어 들여지고, 라우터의 인터페이스가 초기화된다. 마지막으로 구성파일이
로드되면서 인터페이스가 설정되고 라우팅 과정이 시작된다.

명령어
내 용
•Router#show version
구성레지스터 값 확인 / 버전 확인
•Router#configure terminal
•Router(config)#config-register 0x2102
구성 레지스터 값 변경
•Router#configure terminal
•Router(config)#boot system rom
•Router(config)#boot system flash version11-3
(파일이름)
•Router(config)#boot system tftp version11-3
192.168.1.1
IOS 이미지 파일의 위치 지정
rom을 이용한 부팅지정
flash 메모리로부터 IOS 파일 로딩지정
네트워크내의 192.168.1.1에서 IOS 파일
찾도록 지정

▲ router access 모드와 프롬프트 상태

모 드
프롬프트 상태
방 법
• User EXEC
Router>
콘솔, 텔넷, aux 포트로 로그인
• Privilege EXEC
Router#
user 모드에서 enable 입력
• 글로벌 구성
Router(config)#
Privilege 모드에서 configure terminal 입력
• 인터페이스 구성
Router(config-if)#
글로벌 모드에서 interface type number 입력
• 라인구성
Router(config-line)#
글로벌 모드에서 line type number 입력


▲ router 재부팅 명령
명령어
내 용
• Router#erase startup-config
• Router#reload
라우터 현 설정사항을 삭제하고
재부팅 / 셋팅

▲ router access시 password 셋팅
access 수단
password 셋팅
비고
• 콘솔포트
Router(config)# line con 0
Router(config-line)#login
Router(config-line)#password 12345
콘솔포트 : 1개
• 보조포트(Aux)
Router(config)# line aux 0
Router(config-line)#login
Router(config-line)#password 12345
보조포트 : 1개
• 가상터미널
(텔넷세션)
Router(config)# line vty 0 4
Router(config-line)#login
Router(config-line)#password 12345
동시 5개의 텔넷 세션 허용
: 0 ~4
• privilege 모드 진입시
Router#configure terminal
Router(config)# enable password 12345
privilege 모드 진입시
입력하는 패스워드 설정
Router#configure terminal
Router(config)# enable secret 12345
IOS 10.3 이상버전에서
사용되는 privilege 모드
진입시 입력하는 패스워드
설정
enable 패스워드 보다
우선적용

▲ 명령어 히스토리 기능
: history 버퍼를 통해 이전에 입력한 명령어들을 기억(기본 : 최근 10개 명령어 기억)
명령어
내 용
• Router#terminal history size 20
history size를 10에서 20으로 변경
• Router#show history
history 버퍼내용 표시
• Router#terminal no history
history 기능 미사용시

▲ router 이름(host명) 변경
명령어
내 용
• Router#conf t
• Router(config)# hostname Myrouter
 Myrouter(config)#
라우터이름을 Myrouter로 변경

▲ Banner 표시
: 사용자들이 로그온 하기전이나 직후의 메시지를 보여주는 기능
banner 종료
명령어
내용
• MOTD
(Message-of-the-day)
Router(config)#banner motd #
메시지 입력 #
메시지 입력 후 ‘#’으로 종료
• 로드인
Router(config)#banner login #
메시지 입력 #
motd 메시지 다음으로
로그인 전에 나타나는 메시지
• Incoming
Router(config)#banner incoming #
메시지 입력 #
텔넷 세션 접속후 나타나는 메시지
• Exec
Router(config)#banner exec #
메시지 입력 #
텔넷 세션을 제외한 다른 모든접속시
나타나는 메시지

▲ 설명의 추가
: 인터페이스에 대한 설명등, 설정에 대한 설명을 표시
명령어
내 용
• Router#conf t
• Router(config)# interface serial 0
• Router(config-if)# description T1 line between 서울 and 대전
serial 0번 포트에 대한 설명 입력

▲ 편집기능
: 명령어의 편집 및 전후 스크롤 기능
명령어
내 용
• Router>terminal no editing
• Router>terminal editing
편집모드 on
편집모드 off

● 명령어 라인 주위의 이동
명령
내 용
• 왼쪽 화살표 또는 Ctrl+B
• 오른쪽 화살표 또는 Ctrl+F
• Ctrl+A
• Ctrl+E
• Ctrl+B
• Ctrl+F
한 캐릭터 뒤로 이동
한 캐릭터 앞으로 이동
행의 처음으로 이동
행의 마지막으로 이동
한 단어 뒤로 이동
한 단어 앞으로 이동

● 텍스트 삭제
명령
내 용
• Delete/backspace
• Ctrl+D
• Ctrl+K
• Ctrl+U 또는 Ctrl+X
• Ctrl+W
• Esc+D
커서 왼편의 문자를 삭제
커서가 위치한 문자를 삭제
커서로부터 오른쪽을 삭제
커서로부터 왼쪽을 삭제
커서 왼쪽의 단어를 삭제
커서 오른쪽의 단어를 삭제
※ enter 키 : 명령어 한 줄씩 스크롤 다운
space bar 키 : 명령어 한 페이지씩 스크롤 다운

▲ 시간 setting
: 라우터내의 시간설정
명령어
내 용
• Router#clock set ?
clock set 다음 시간, 분, 초 등 나머지 값들을 입력
정확히 모를 경우 ‘?’ 사용
clock set 다음의 값들을 확인

▲ IOS 이미지 이동 명령
명령어
내 용
• Router#configure terminal
• Router(config)# copy flash tftp
flash 메모리의 IOS 이미지를 다른 위치로 이동하기위한
명령어로 copy flash tftp 입력시 IP주소와 IOS 이미지
이름을 요구하게 됨
그것에 따른 정확한 IP와 이미지 파일 이름을 입력

▲ show 기본 명령어
명령어
내 용
•Router#show buffers
버퍼를 통과하는 데이터 패킷에 대한 통계 수치 나열
•Router#show cdp entry hostname
•Router#show cdp neighbor
•Router#show cdp interface
인접장비의 설정정보를 보여줌(정확한 장비명을 알 경우)
라우터와 직접연결된 장비들의 정보를 보여줌
어떤 인터페이스가 cdp를 사용하고 있는지 알려줌
※cdp(cisco discovery protocol)
•Router#show flash
플래시 메모리에 현재 어떠한 IOS 이미지 파일이
저장되어 있는지 보여줌
•Router#show hosts
라우터에 저장된 host 이름과 주소표를 보여줌
•Router#show interfaces
라우터 인터페이스에 대한 설정과 작동상태를 보여줌
•Router#show interface serial 0
serial 0에 대한 인터페이스 정보를 보여줌
•Router#show ip interface
ip 인터페이스의 ip 설정 사항과 주소를 보여줌
line protocol is down 상태
- 인터페이스 장애 or
인터페이스는 작동하지만 신호를 보내지 않는상태
•Router#show ip protocols
설정된 ip라우터 프로토콜과 관련정보를 보여줌
•Router#show ipx interface
ipx 인터페이스의 설정 사항과 주소를 보여줌
•Router#show memory
라우터의 모든 메모리와 사용통계를 보여줌
•Router#show processes
라우터에서 실행되고 있는 프로세스를 보여줌
•Router#show protocols
라우터에 설정된 모든 layer3 프로토콜 정보를 보여줌
•Router#show stack
스택 사용률이나 인터럽트 루틴을 알아볼때 사용
•Router#show version
버전정보, 어디에위치한 부트 이미지를 사용했는지
얼마나 오랬동안 문제 없이 사용됐는지 등의 정보를
알려줌
•Router#show running-config
현재 작동중인 라우터의 설정사항을 보여줌
(현재 운용에 관련된 설정정보)
저장을 안하고 재부팅시 적용이 안됨
•Router#show startup-config
장비가 NVRAM에 저장된 설정 사항을 시작할 때
사용하는데 그 내용을 보여줌
Router#copy running-config startup-config
running-config의 내용을 startup-config의 내용으로
저장할 때 사용
※ IOS 10.3 이상의 경우 :
Router#write memory 명령어도 동일 기능수행

▲ 라우터 포트에 주소셋팅(ip 할당)
명령어
내 용
• Router#conf t
• Router(config)#interface serial0
• Router(config-if)#ip address 192.168.2.1 255.255.255.0
• Router(config-if)#description E1 line
serial0번 포트에 192.168.2.1 의 IP 주소를
할당
서브넷은 255.255.255.0 이며, E1 라인임을
설명

▲ 라우팅 table 보기
명령어
내 용
• Router#show ip route
라우터에 설정된 주소와 포트 관계를 보여줌
※ 보여지는 routing table에서 ‘C’ : 직접연결, ‘S’ : 정적경로(static)를 의미

▲ 정적(static)경로 설정


: 위 그림에서 Router_A의 경로 설정의 경우
명령어
내 용
• Router_A#conf t
• Router_A(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
• Router_A(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.2
• Router_A(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.2
목적지네트웍주소, 서브넷
기본gateway의 형식으로
3개의 목적지 주소로 패킷을
보내기 위해서는
모두 router_B의 s0 포트로
기본 gateway를 설정

▲ 기본(default)경로 설정
: 6 페이지 그림 적용 Router_A의 기본경로를 설정할 경우
명령어
내 용
• Router_A#conf t
• Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
모든 목적지 네트워크 및 알지 못하는 목적지
네트워크주소의 패킷을 받았을 경우
모두 router_B의 s0 포트로 전달

● Router_C의 경우
명령어
내 용
• Router_A#conf t
• Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
모든 목적지 네트워크 및 알지 못하는 목적지
네트워크주소의 패킷을 받았을 경우
모두 router_B의 s1 포트로 전달
※ 경로 해지시
명령어
내 용
• Router_A#conf t
• Router_A(config)#no ip route 0.0.0.0 0.0.0.0 192.168.4.1

▲ 동적(dynamic)경로 설정
: 시스코라우터의 동적 라우팅 프로토콜은
• RIP(Routing Information Protocol),
- 최대홉수 : 15
- 30초 간격으로 라우터간 라우팅 table 업데이트
 IGRP(Interior Gateway Routing Protocol : 시스코 라우터와 이기종간에는 사용불가),
- 다중경로 라우팅 지원(최대 4개 경로 지원),
- 최대홉수 : 255
- 90초 간격으로 라우터간 라우팅 table 업데이트
 EIGRP(Enhanced Interior Gateway Routing Protocol)
- 토폴로지 변경시에만 라우팅 table 업데이트,
※동적경로 설정은 : 라우팅 프로토콜을 사용하여 자동적으로 경로를 발견하는 라우팅 방법

 RIP 설정
: 6 페이지 그림 적용 Router_A의 RIP를 설정할 경우
명령어
내 용
• Router_A#conf t
• Router_A(config)#router rip
• Router_A(config-router)#network 192.168.1.0
• Router_A(config-router)#network 192.168.2.0
rip 라우팅을 시작하기 위해 rip 설정(router rip)
Router_A가 보유하고 있는 시리얼, 이터넷 포트의
네트워크 주소 입력
※ RIP 설정 전에 기존에 설정된 static, default 경로는 삭제한다.
no ip route 명령어 사용
: 6 페이지 그림 적용 Router_B의 RIP를 설정할 경우

명령어
내 용
• Router_A#conf t
• Router_A(config)#router rip
• Router_A(config-router)#network 192.168.2.0
• Router_A(config-router)#network 192.168.3.0
• Router_A(config-router)#network 192.168.4.0
rip 라우팅을 시작하기 위해 rip 설정(router rip)
Router_B가 보유하고 있는 시리얼, 이터넷 포트의
네트워크 주소 입력

● Passive RIP 설정
: 라우팅 업데이트 내용을 인접 라우터에게 보내지 않게 하는 기능
즉, 이더넷 인터페이스에는 라우팅 업데이트 내용이 불필요하기 때문에, 주기적인 업데이트 내용
으로 불필요한 트래픽이 발생하는 것을 방지
명령어
내 용
• Router_A#conf t
• Router_A(config)#router rip
• Router_A(config-router)#passive-interface ethernet0
Router_A의 이더넷 0번 포트로는
라우팅 업데이트를 하지 않는다.

● neighbor RIP 설정
: 자동 라우팅 업데이트시 전달이 안되는 경우도 발생할수 있기 때문에 받드시 라우팅 업데이트
내용을 받아야할 인접 라우터를 설정하는 기능
명령어
내 용
• Router_A#conf t
• Router_A(config)#router rip
• Router_A(config-router)#neighbor x.x.x.x
Router_A의 라우팅 업데이트 내용
을 반드시 받아야하는 라우터의 IP
주소를 입력

▲ RIP 모니터링
명령어
내 용
• Router_A#show ip route
전체적인 라우팅 정보를 보여줌
• Router_A#show ip protocol
어떤라우팅 프로토콜을 사용하는지, 라우팅 업데이트 간격,
프로코콜에 관련된 timer 정보, 프로토콜 버전 넘버
라우팅 되는 IP, 라우팅 업데이트를 받고있는 IP 주소등을
보여줌
• Router_A#show ip interface
인터페이스별 상세 정보를 보여줌
• Router_A#debug ip rip
• Router_A#no debug ip rip
rip 라우팅 업데이를 실시간으로 확인
각 항목에 대한 보내는 업데이트 인지 받는 업데이트인지
구분되고, 업데이트를 보내고 받는 장비의 주소도
정확하게 보여줌
모니터링 완료후 입력
•Router_A#trace x.x.x.x
마지막 목적지 x.x.x.x 까지 도착하기 위해서 패킷이
거치고 있는 모든 홉 라우터 정보를 수집, 보여줌

 IGRP 설정
: 6 페이지 그림 적용 Router_A의 IGRP를 설정할 경우
명령어
내 용
• Router_A#conf t
• Router_A(config)#no router rip
IGRP 라우팅을 시작하기 위해 rip 설정을 삭제
(no router rip)
• Router_A(config)#router igrp 100
igrp 라우팅을 위해 as 넘버 입력 ‘100'
as 넘버는 : 1~65535 사이의 임의의 숫자
• Router_A(config-router)#network 192.168.1.0
• Router_A(config-router)#network 192.168.2.0

▲ IGRP 모니터링
: RIP 모니터링과 동일
명령어
내 용
• Router_A#debug ip igrp transaction
• Router_A#debug ip igrp events
•igrp 라우팅 업데이를 실시간으로 확인
각 항목에 대한 보내는 업데이트 인지 받는 업데이트인지
구분되고, 업데이트를 보내고 받는 장비의 주소도
정확하게 보여줌
요약 정보를 보여줌
※ 라우터 인터페이스에 clocking 및 대역폭값 설정
: 경로선택시 참고되는 값으로만 사용되며, 실제 속도는 회선이 물리적으로 제공하는
대역폭을 사용한다.
명령어
내 용
• Router_A#conf t
• Router_A(config)#interface s0
• Router_A(config-if)#clock rate 56000
• Router_A(config-if)#bandwidth 56
•시리얼0 번포트의 clock을 56K
(DCE와 연결을위한 clock 설정)
대역폭을 56K로 설정

▲ WAN 접속 기초

● DTE(Data Terminal Equipment)
◦ 컴퓨터, 터미널, 브리지, 라우터와 같이 WAN 구간을 통해서 다른 DTE
장비와 통신할 수 있는 장비들
◦ 네트워크에서 데이터를 이동시키기 보다는 데이터를 생성하고 처리하는 일을 담당
◦ DTE 장비는 DCE 장비로부터 생성된 clocking 신호를 바탕으로 원격지 네트워크에
있는 다른 DTE 장비와도 동기화(synchronization)를 할 수 있게 된다.

● DCE(Data Communication Equipment)
◦ DTE의 통신을 위해서 접속성을 제공하고, clocking 신호도 제공한다.
◦ 네트워크에서 데이터를 이동하는 일을 담당

● 동기식 통신(Synchronous communication)
◦ 동기화 통신은 데이터 전송시 양 끝단에 동기화된 clocking 시스템의 있고 없음에 많은
영향을 받으며, clocking의 동기화가 중요한 이유는 동기화가 없다면 데이터를 받는 장비가
데이터의 시작과 끝을 구분할 수 없기 때문이다.
◦ 예를 들어 데이터 스트림에 clocking 정보를 넣어 동기화를 시도
- 데이터 스트림 시작전에 ‘01111110’ 으로 구성된 starting bit pattern을 사용
데이터 스트림의 시작을 알린다.
- ‘01111110’ - 데이터(8) - 데이터(8) - ∙ ∙ ∙ - ‘01111110’
● 비동기식 통신(Asynchronous communication)
◦ 동기식과는 반대로 clock를 사용하는 것이 아니라 추가적인 비트 사용으로 데이터 스트림의
시작과 끝을 구분
◦ 하나의 데이터를 표현하기위해 총 10bit 사용
- start bit(1) - 데이터(8) - stop bit(1)

● Point -to-Point 회선방식
◦ 두개의 시스템에 의해서 사용되는 회선(전용회선)

● Circuit-Switching 회선방식
◦ 네트워크 A와 네트워크 B 간에 서비스 공급자 회선을 사용
◦ 이 세션을 임시적이며, 통신이 끝나면 소멸되나 세션이 성립되어 있는 동안
각 데이터 프레임은 동일 경로로 데이터가 전송됨
※여러개의 point-to-point 회선을 임시적으로 사용하는 방식

● Packet-Switching 회선방식
◦ 네트워크 A와 네트워크 B 간에 서비스 공급자의 공유된 회선을 사용
◦ 네트워크 A에서 B로 데이터를 전송할 경우 각 데이터 프레임이 다른 경로로
전송될 수 있음

 WAN encapsulation 프로토콜
: encapsulation 프로토콜은 데이터링크 계층에서 데이터를 프레임으로 변환시켜 주기 위해
사용되는 프로토콜이다.
즉, 상위계층에서 받은 데이터를 header와 footer로 감싸서 데이터 프레임으로 만든다.
※ 라우터와 라우터 연결시 사용 프로토콜 : HDLC, PPP

● X.25
: 패킷 스위치 네트워크에서 사용되는 표준으로 각 스위치에서 에러확인/정정을 실시하여
데이터의 신뢰성을 제공
 네트워크 계층에서 데이터가 패킷으로 쪼개지는 과정과 가상 circuit이 만들어지는 방법을 정의
◦ 데이터 링크계층에서 데이터 프레임이 어떻게 만들어 지는지를 구체화
◦ 물리계층에서 회선을 통해 전기신호를 보내는 방식을 정의

▲ X.25 설정
◦ router A, B, C에서 router B를 X.25 스위치로 설정
◦ router A
- IP : 192. 168.0.1
- X.121 : 123456789012
◦ router C
- IP : 192. 168.0.2
- X.121 : 123456789013

● Router B 스위치 설정
명령어
내 용
• Router_B#conf t
• Router_B(config)#x.25 routing
• Router_B(config)#interface serial0
• Router_B(config-if)#encapsulation x.25 dce
• Router_B(config-if)#clock rate 9600
• Router_B(config-if)#no shutdown
x.25 라우팅을 할수 있도록 설정
s0 포트를 encapsulation 시킨후
dce 장비로 사용할 수 있도록
clock rate를 9600kbps로 설정
• Router_B#conf t
• Router_B(config)#x.25 routing
• Router_B(config)#interface serial1
• Router_B(config-if)#encapsulation x.25 dce
• Router_B(config-if)#clock rate 9600
• Router_B(config-if)#no shutdown
x.25 라우팅을 할수 있도록 설정
s1 포트를 encapsulation 시킨후
dce 장비로 사용할 수 있도록
clock rate를 9600kbps로 설정
• Router_B(config)#x25 route 123456789012 interface s0
• Router_B(config)#x25 route 123456789013 interface s1
PVC 매핑
- x.121 주소 : 123456789012
로 향하는 프레임은 s0으로
- x.121 주소 : 123456789013
로 향하는 프레임은 s1로
매핑

● Router A 설정
명령어
내 용
• Router_A#conf t
• Router_A(config)#interface serial0
• Router_A(config-if)#encapsulation x.25
• Router_A(config-if)#x.25 address 123456789012
• Router_A(config-if)#ip address 192.168.0.1 255.255.255.0
시리얼 0번포트에
x.25 encapsulation
x.25 주소설정
ip 주소 설정
• Router_A(config-if)#x.25 map ip 192.168.0.2 123456789013 broadcast
• Router_A(config-if)#no shut
x.25 경로 설정으로
라우터 C로 향하는 트래픽
을 라우터 C의 x.121 주소로
매핑

● Router C 설정
명령어
내 용
• Router_C#conf t
• Router_C(config)#interface serial0
• Router_C(config-if)#encapsulation x.25
• Router_C(config-if)#x.25 address 123456789013
• Router_C(config-if)#ip address 192.168.0.2 255.255.255.0
시리얼 0번포트에
x.25 encapsulation
x.25 주소설정
ip 주소 설정
• Router_C(config-if)#x.25 map ip 192.168.0.1 123456789012 broadcast
• Router_C(config-if)#no shut
x.25 경로 설정으로
라우터 A 향하는 트래픽
을 라우터 A의 x.121 주소로
매핑

● X.25 주소와 IP주소의 매핑상태 확인
명령어
내 용
• Router_A#show x.25 map
x.121 주소와 ip 주소의
매핑 상태를 보여줌

▲ frame-relay 설정
◦ router A, B, C에서 router B를 프레임 릴레이 스위치로 설정
◦ router A
- IP : 192. 168.0.1
- DLCI : 17
※DLCI(Data-Link Connection Identifiers)
◦ router C
- IP : 192. 168.0.2
- DLCI : 18

● Router B 스위치 설정
명령어
내 용
• Router_B#conf t
• Router_B(config)#frame-relay switching
• Router_B(config)#interface serial0
• Router_B(config-if)#encapsulation frame-relay
• Router_B(config-if)#clock rate 56000
• Router_B(config-if)#frame-relay intf-type dce
• Router_B(config-if)#frame-relay route 17 interface s1 18
frame-realy interface type을
dce로 설정(dce 기능 수행위해)
DLCI 17에서 들어오는 트래릭은
s1 포트를 통해 DLCI 18로
향하도록 설정
• Router_B#conf t
• Router_B(config)#frame-relay switching
• Router_B(config)#interface serial0
• Router_B(config-if)#encapsulation frame-relay
• Router_B(config-if)#clock rate 56000
• Router_B(config-if)#frame-relay intf-type dce
• Router_B(config-if)#frame-relay route 18 interface s0 17
frame-realy interface type을
dce로 설정(dce 기능 수행위해)
DLCI 18에서 들어오는 트래릭은
s0 포트를 통해 DLCI 17로
향하도록 설정

● Router A 설정
명령어
내 용
• Router_A#conf t
• Router_A(config)#interface serial0
• Router_A(config-if)#ip address 192.168.0.1 255.255.255.0
• Router_A(config-if)#encapsulation frame-relay
• Router_A(config-if)#frame-relay interface-dlci 17
• Router_A(config-if)#frame-relay map ip 192.168.0.1 17
• Router_A(config-if-dlci)#frame-relay lmi-type cisco
시리얼 0번포트에
ip 주소 설정
dlci 설정(17)
ip주소와 dlci 매핑
lmi type 설정

● Router_C 설정
명령어
내 용
• Router_C#conf t
• Router_C(config)#interface serial0
• Router_C(config-if)#ip address 192.168.0.2 255.255.255.0
• Router_C(config-if)#encapsulation frame-relay
• Router_C(config-if)#frame-relay interface-dlci 18
• Router_C(config-if)#frame-relay map ip 192.168.0.2 18
• Router_C(config-if-dlci)#frame-relay lmi-type cisco
시리얼 0번포트에
ip 주소 설정
dlci 설정(18)
ip주소와 dlci 매핑
lmi type 설정
※ LMI(Local Management Interface) type
: 시스코 라우터의 인터페이스는 서비스 공급자의 LMI 종류와 동일 해야지만 올바르게 작동
◦ 시스코 IOS 11.2 이상 버전은 자동으로 LMI 감지(설정 미필요)
◦ 세가지 LMI type
- ANSI
- q933a : ITU-T 방식
- cisco : 시스코 라우터 기본 설정값
※ frame-relay address 매핑
: Inverse-arp 사용 : 자동으로 네트워크 주소를 DLCI 넘버에 매핑
◦ 시스코 라우터 자동매핑 기본 제공(frame-relay map ip ..... 설정 미필요)

● frame-relay 설정확인 및 매핑 확인
명령어
내 용
• Router_A#show frame-relay pvc
모든 PVC와 DLCI 셋팅 정보 확인
프레임 릴레이 설정사항과 혼잡정보 제공
• Router_A#show frame-relay map
모든 네트워크 주소와 DLCI 매핑관계를 보여줌

▲ 네트워크 보안(access-list)셋팅

● IP standard access-list 셋팅
명령어
내 용
• Router#conf t
• Router(config)#access-list 1 permit 10.28.0.1 0.0.0.0
• Router(config)#access-list 1 deny 10.28.0.0 0.0.255.255
• Router(config)#access-list 1 permit 10.0.0.0 0.255.255.255
10.28.0.1 로부터 발생하는 모든
ip 트래픽 허용
10.28.0.0 로부터 발생하는 모든
ip 트래픽 무시
10.0.0.0 로부터 발생하는 모든
ip 트래픽 허용
※ 이외의 모든 트래픽은 무시
• Router(config)#access-list 1 permit any
모든 ip 패킷 허용

● IP extended access-list 셋팅
명령어
내 용
• Router#conf t
• Router(config)#access-list 101 permit ip any host 10.0.0.1
•모든 ip 패킷은 목적지가
10.0.0.1인 것은 허용
 Router(config)#access-list 101 permit tcp 10.30.0.0 0.0.255.255 any
•10.30.0.0 의 네트워크 주소에서
발생하는 tcp 트래픽만 허용
 Router(config)#access-list 101 permit ip any any
•모든 ip 트래픽 허용
 Router(config)#access-list 101 permit tcp any 10.30.0.0 0.0.255.255
eq 80
소스에 상관없이 tcp 트래픽중
80번 포트를 사용하는 web
트래픽이면서 10.30.0.0 네트워크
로 향하는 트래픽만 허용
 Router(config)#access-list 101 permit tcp any 10.30.0.0 0.0.0.0
eq 25
소스에 상관없이 tcp 트래픽중
25번 포트를 사용하는
smtp 트래픽이면서 10.30.0.0
네트워크로 향하는 트래픽만
허용

● access-list 인터페이스에 적용
명령어
내 용
• Router#conf t
• Router(config)#int e0
• Router(config-if)#ip access-group 1 in
•standard access list 1을 이더넷 0번 포트에
적용되면서 inbound 되는 트래픽에 대해서
필터링 실시(이더넷 0번 포트를 통해서
들어오는 트래픽 필터링)
• Router(config-if)#ip access-group 101 out
•extendes access list 101을 이더넷 0번 포트에
적용되면서 outbound 되는 트래픽에 대해서
필터링 실시(이더넷 0번포트를 통해서
나가는 트래픽 필터링)

● access-list 지우기
명령어
내 용
• Router#conf t
• Router(config)#int e0
• Router(config-if)#no ip access-group 1 in
•이더넷 0번 포트에
적용된 access-list 삭제
• Router(config-if)#no access-list 101
•access-list 101 자체삭제

● access-list 모니터링
명령어
내 용
• Router#show access-lists
•모든 access-list 설정확인
• Router#show ip access-lists
•ip 와 관련된 access-list 설정확인

▲ password 복구
◦ 라우터의 콘솔에 연결한 후 라우터의 전원을 껐다 켠다
◦ Rom monitor 부팅
- break, shift+break. ctrl+break 키 사용 부팅
◦ configuration register 값 확인
명령어
내 용
• Router>e/s 2000002
2000002 : 2102
•e/s 2000002 입력시 2102라는 값 확인
◦ configuration register 값 = oxffff2102확인
◦ 'q'를 입력 프롬프트를 빠져나간다.
◦ configuration register 값 조정

명령어
내 용
• Router>o/r 0x42
•configuration register 비트를 6을 설정
라우터가 NVRAM에 있는 설정값을
무시 할수 있도록 한다.
• Router>i
•라우터 재부팅
◦ 라우터 재부팅시 자동설정하지 않도록 : no 입력
◦ enable 모드로 진입
명령어
내 용
• Router>en
• Router#
•패스워드를 물어보지 않는다.
• Router#copy star run
•starting configuration 파일을 running 파일에
복사
◦ enable password 및 line password 확인
명령어
내 용
• Router#show run
◦ 새로운 password 입력 및 NVRAM 설정을 부팅시 마다 사용토록 설정
명령어
내 용
• Router#conf t
• Router(config)#enable secret 12345
• Router(config)#config-register 0x2102



출처 : http://knyatom.egloos.com/

0 Comments
댓글쓰기 폼